Titre

PowerShell - Pre-requis

Couvrir les pre-requis necessaires pour commencer a programmer en PowerShell. Ces derniers sont surtout necessaires pour Windows XP.

Télécharger la vidéo: clic droit ici

Pour connaitre la police Powershell actuellement en place vous pouvez taper la commande

Lien vers le fichier : cliquez ici

On voit ici que l'on est à la valeur par défaut cad Restricted,
ce qui empêche la bonne exécution des scripts

Il faut modifier cela et on va donc autoriser les scripts PowerShell avec la commande

Lien vers le fichier : cliquez ici

Pour un accès libre la commande est

Lien vers le fichier : cliquez ici

Si la commande précédente ne passe pas, essayez celle-ci :

Lien vers le fichier : cliquez ici

Il y a différents niveaux de sécurité :

Commande Utilité
set-executionpolicy Restricted No scripts can be run. Windows PowerShell can be used only in interactive mode
set-executionpolicy AllSigned Only scripts signed by a trusted publisher can be run
set-executionpolicy RemoteSigned Downloaded scripts must be signed by a trusted publisher before they can be run
set-executionpolicy Unrestricted No restrictions; all Windows PowerShell scripts can be run

La commande pour savoir dans quel niveau de sécurité vous êtes actuellement est
Get-ExecutionPolicy

L'équivalent de la première commande en GPO

Via les clés de registre, en copier/coller le résultat est plus fiable et immédiat

Lien vers le fichier : cliquez ici

Si vous avez besoin d'accéder à l'AD, pour éviter d'avoir ce message

Dans les Features, ajoutez ce module :

Pages Web

Site WebDescription
Ms FrameWork 2.0 SP1 x86FrameWork 2.0 SP1 x86
Ms FrameWork 3.5 SP1Ms FrameWork 3.5 SP1
PowerShell V2PowerShell V2. Chercher Windows Management Framework Core
Plug in ActiveRolesPlug in ActiveRoles de Quest pour gérer l'AD
PowerGuiPowerGui - Interface de développement
Citrix.com CTX126125How to Replicate Print Drivers with PowerShell in XenApp 6.x

Téléchargement(s)

Article(s) suivant(s)

Article(s) précédent(s)

Article(s) en relation